Dash Lights not working. Cant see my dials in the dark!

Need technical Q/A then you're in the right place
Post Reply
User avatar
dan_lboro
E30 Zone Newbie
E30 Zone Newbie
Posts: 50
Joined: Thu May 05, 2016 10:00 pm

Mon Jun 13, 2016 9:46 pm

I bought an e30 cabriolet about 6 weeks ago and i'm still fixing bits on it. At the weekend it was the first time I had driven it in the dark and the dashboard dials were not illuminated so I cant see how fast Im going! I tried rotating the head light nob clockwise and the dash lights still dont work. Does anyone have any ideas please? Thanks
manse73
E30 Zone Camper
E30 Zone Camper
Posts: 1110
Joined: Sat Mar 20, 2010 11:00 pm
Location: in a town near you

Mon Jun 13, 2016 10:33 pm

head torch :D
bruv chariots rule
User avatar
andysheep
E30 Zone Regular
E30 Zone Regular
Posts: 444
Joined: Sun Jul 12, 2009 10:00 pm
Location: Abersoch north wales

Mon Jun 13, 2016 10:41 pm

Remove the bincale and check bulbs,or you may need a new/second hand head light switch,but first may be fuze check,ya never know :D sure brian will be along soon,unless hes still enjoying the old vino still on holiday,andy,by the way i had thisproblem,dont worry you'll be ok :D
User avatar
BenHar
E30 Zone Addict
E30 Zone Addict
Posts: 2495
Joined: Sun Jul 11, 2010 10:00 pm
Location: Reigate, Surrey

Tue Jun 14, 2016 10:47 am

Make sure the light switch is turned full clockwise.

Ben

I should have read the original post properly. Thanks JMC.
Last edited by BenHar on Tue Jun 14, 2016 1:17 pm, edited 1 time in total.
jmc330i
Engaged to the E30 Zone
Engaged to the E30 Zone
Posts: 6617
Joined: Mon Jan 10, 2005 11:00 pm
Location: Somerset

Tue Jun 14, 2016 11:20 am

BenHar wrote:Make sure the light switch is turned full clockwise.

Ben
dan_lboro wrote: I tried rotating the head light nob clockwise.
:P :P
James
'91 325i Sport
'93 318i touring 16v
User avatar
dan_lboro
E30 Zone Newbie
E30 Zone Newbie
Posts: 50
Joined: Thu May 05, 2016 10:00 pm

Tue Jun 14, 2016 12:11 pm

Cheers, I will have a go and let you know how it goes.
Rav335uk
E30 Zone Meets/Events Team
E30 Zone Meets/Events Team
Posts: 27978
Joined: Wed Jan 19, 2005 11:00 pm
Location: Mad mad mad
Contact:

Tue Jun 14, 2016 12:46 pm

Have you checked fuse 10? 7.5amp
Image
If you Got "Haters",Then your doing something Right!
CR24v??? Where's it all gone?? LOL
User avatar
dan_lboro
E30 Zone Newbie
E30 Zone Newbie
Posts: 50
Joined: Thu May 05, 2016 10:00 pm

Tue Jun 14, 2016 12:50 pm

Not yet. Will do. Thanks. I understand that there are 2 dash bulbs, so assuming they are both wired in series then it sounds like it could be a fuse.
User avatar
BenHar
E30 Zone Addict
E30 Zone Addict
Posts: 2495
Joined: Sun Jul 11, 2010 10:00 pm
Location: Reigate, Surrey

Tue Jun 14, 2016 1:20 pm

User avatar
dan_lboro
E30 Zone Newbie
E30 Zone Newbie
Posts: 50
Joined: Thu May 05, 2016 10:00 pm

Tue Jun 14, 2016 2:25 pm

Cheers Ben, that thread is really good
User avatar
dan_lboro
E30 Zone Newbie
E30 Zone Newbie
Posts: 50
Joined: Thu May 05, 2016 10:00 pm

Wed Jun 15, 2016 10:28 pm

Checked the fuse and that was ok. Then I took the cover below the steering wheel off to access the headlight switch and found 2 bulbs, which work with the headlight switch so I'm 99.9% sure these are the bulbs. Image
User avatar
dan_lboro
E30 Zone Newbie
E30 Zone Newbie
Posts: 50
Joined: Thu May 05, 2016 10:00 pm

Wed Jun 15, 2016 10:29 pm

Image
User avatar
dan_lboro
E30 Zone Newbie
E30 Zone Newbie
Posts: 50
Joined: Thu May 05, 2016 10:00 pm

Wed Jun 15, 2016 10:31 pm

When its stopped raining I plan on following this thread (http://www.e30zone.net/e30zonewiki/inde ... eplacement) and putting the lights back in. I love a happy ending :D :D :D :D
User avatar
BenHar
E30 Zone Addict
E30 Zone Addict
Posts: 2495
Joined: Sun Jul 11, 2010 10:00 pm
Location: Reigate, Surrey

Wed Jun 15, 2016 10:32 pm

Those are the bulbs to illuminate the headlight leveling knob.

They are on a separate circuit from the dash lights.

Follow the intsructions in the link I posted to check what's wrong.

Ben
User avatar
andysheep
E30 Zone Regular
E30 Zone Regular
Posts: 444
Joined: Sun Jul 12, 2009 10:00 pm
Location: Abersoch north wales

Wed Jun 15, 2016 11:06 pm

Keep going youll sort it :D these are all the things i went through,you will get there,andy
User avatar
Brianmoooore
E30 Zone Team Member
E30 Zone Team Member
Posts: 47552
Joined: Mon Jan 10, 2005 11:00 pm

Thu Jun 16, 2016 9:38 am

BenHar wrote: They are on a separate circuit from the dash lights.
They're not , you know! They're on exactly the same circuit as the instrument cluster illumination bulbs, so you can eliminate any problems with switches, fuses and dimmers. It's the foglight/main light switch illumination bulb that's separate.
The fact that one of the leveller bulbs is blown shows that the bulbs are reaching their design life, so I suggest you buy two 3W (NOT the more common 5W version) capless bulbs, and change them anyway.
Image
User avatar
dan_lboro
E30 Zone Newbie
E30 Zone Newbie
Posts: 50
Joined: Thu May 05, 2016 10:00 pm

Thu Jun 16, 2016 12:12 pm

Thank you very much for the help. I finish early on fridays, so planning on getting some new bulbs and stripping the dash back so I can see whats going on. Will keep you posted on how it goes. :D
User avatar
BenHar
E30 Zone Addict
E30 Zone Addict
Posts: 2495
Joined: Sun Jul 11, 2010 10:00 pm
Location: Reigate, Surrey

Thu Jun 16, 2016 4:46 pm

Brianmoooore wrote:
BenHar wrote: They are on a separate circuit from the dash lights.
They're not , you know! They're on exactly the same circuit as the instrument cluster illumination bulbs, them anyway.
Why don't they dim with the dashlights then?

Ben
SkyKnight
E30 Zone Newbie
E30 Zone Newbie
Posts: 7
Joined: Sat Dec 01, 2012 11:00 pm
Location: Cape Town, South Africa

Sun Jun 19, 2016 10:20 am

More than likely the switch, I had that issue on mine a year or two ago, I don't remember the details, but bridged two connections in the plug that goes into the switch and I had my dash lights back again, worked ever since, but you do lose the dimmer facility, i am not worried about it,i have never in all the years of driving my beemer, had to dim the dash lights.
E30's are not built, they are born in the wild.
User avatar
BenHar
E30 Zone Addict
E30 Zone Addict
Posts: 2495
Joined: Sun Jul 11, 2010 10:00 pm
Location: Reigate, Surrey

Thu Jun 23, 2016 1:14 pm

BenHar wrote:
Brianmoooore wrote:
BenHar wrote: They are on a separate circuit from the dash lights.
They're not , you know! They're on exactly the same circuit as the instrument cluster illumination bulbs, them anyway.
Why don't they dim with the dashlights then?

Ben
I would like to know the answer to this. Seems odd to me.

Ben
User avatar
Brianmoooore
E30 Zone Team Member
E30 Zone Team Member
Posts: 47552
Joined: Mon Jan 10, 2005 11:00 pm

Sun Jun 26, 2016 7:53 pm

BenHar wrote:
Brianmoooore wrote:
BenHar wrote: They are on a separate circuit from the dash lights.
They're not , you know! They're on exactly the same circuit as the instrument cluster illumination bulbs, them anyway.
Why don't they dim with the dashlights then?

Ben
Partial apology offered! I would have sworn that these bulbs dim with the other dash lights on an E30, but I checked on a loom today, and the earth return from the bulbs does indeed go to a plain brown earth wire, and not the brown/white dimmer wire, so I will have to amend my circuit diagram.
The supply to the bulbs is on exactly the same circuit as the cluster illumination bulbs, so fuse and switch are all OK, but the circuit isn't completed through the dimmer, as it is for the cluster bulbs, so pulling out the rear ashtray bulb holder and shorting the brown/white wire to it to a good body earth with the lights on, and seeing if the cluster light up is the way to go.
Image
Oseanosea
E30 Zone Newbie
E30 Zone Newbie
Posts: 36
Joined: Fri Jan 18, 2019 1:32 am
Location: Jupiter, Florida USA

Sat Feb 09, 2019 6:59 pm

Brianmoooore wrote:
Sun Jun 26, 2016 7:53 pm
BenHar wrote:
Brianmoooore wrote:
They're not , you know! They're on exactly the same circuit as the instrument cluster illumination bulbs, them anyway.
Why don't they dim with the dashlights then?

Ben
Partial apology offered! I would have sworn that these bulbs dim with the other dash lights on an E30, but I checked on a loom today, and the earth return from the bulbs does indeed go to a plain brown earth wire, and not the brown/white dimmer wire, so I will have to amend my circuit diagram.
The supply to the bulbs is on exactly the same circuit as the cluster illumination bulbs, so fuse and switch are all OK, but the circuit isn't completed through the dimmer, as it is for the cluster bulbs, so pulling out the rear ashtray bulb holder and shorting the brown/white wire to it to a good body earth with the lights on, and seeing if the cluster light up is the way to go.
I know this post is almost 3 years old, but I’m commending Brianmoooore anyway. In attempting to troubleshoot my dashboard light issues, amongst other things, I have noticed that Mr. Moooore is very knowledgeable and quick to offer his expertise to those that could benefit. He’s also quick to admit his errors when he or others find them. He even does research to correct himself... a rare individual indeed. Cudos and a long healthy life to you Brian! (I’ll wipe my nose off now & get back to work.)
“Keep lowering your standards until you achieve your goal.”
Oseanosea
E30 Zone Newbie
E30 Zone Newbie
Posts: 36
Joined: Fri Jan 18, 2019 1:32 am
Location: Jupiter, Florida USA

Sat Feb 09, 2019 7:03 pm

BenHar wrote:
Tue Jun 14, 2016 1:20 pm
This may help: http://www.e30zone.net/modules.php?name ... c&t=268529

Ben
I have found several web links that look interesting but connect to Error 404 Not Found. I know this site has recently undergone major updates and upgrades. I’m hoping that these tech articles still exist somewhere. Do they? Thanks all, Sean
“Keep lowering your standards until you achieve your goal.”
User avatar
Brianmoooore
E30 Zone Team Member
E30 Zone Team Member
Posts: 47552
Joined: Mon Jan 10, 2005 11:00 pm

Sat Feb 09, 2019 8:05 pm

Oseanosea wrote:
Sat Feb 09, 2019 7:03 pm

I have found several web links that look interesting but connect to Error 404 Not Found. I know this site has recently undergone major updates and upgrades. I’m hoping that these tech articles still exist somewhere. Do they? Thanks all, Sean
You're correct that the broken links are as a result of the upgrade, and I don't think there's a simple solution to general forum links, but this works for old wiki links: "You just need to take out the zone part of the /e30zonewiki/ to get a link working again."
Image
Oseanosea
E30 Zone Newbie
E30 Zone Newbie
Posts: 36
Joined: Fri Jan 18, 2019 1:32 am
Location: Jupiter, Florida USA

Sat Feb 09, 2019 8:21 pm

Brianmoooore wrote:
Sat Feb 09, 2019 8:05 pm

You're correct that the broken links are as a result of the upgrade, and I don't think there's a simple solution to general forum links, but this works for old wiki links: "You just need to take out the zone part of the /e30zonewiki/ to get a link working again."
Thanks! I’ll try that!
A few minutes ago, I fell across this page, although I can’t remember where, but I did bookmark it:

https://www.e30zone.net/e30wiki/index.p ... =Main_Page

I plan to read it all by tomorrow and have it memorized sometime on Monday.
“Keep lowering your standards until you achieve your goal.”
Oseanosea
E30 Zone Newbie
E30 Zone Newbie
Posts: 36
Joined: Fri Jan 18, 2019 1:32 am
Location: Jupiter, Florida USA

Sat Feb 09, 2019 8:33 pm

Brianmoooore wrote:
Sat Feb 09, 2019 8:05 pm

You're correct that the broken links are as a result of the upgrade, and I don't think there's a simple solution to general forum links, but this works for old wiki links: "You just need to take out the zone part of the /e30zonewiki/ to get a link working again."
I can confirm that removing “zone” from “e30zonewiki” definitely works and I thank you again.
I hope you don’t mind if I create a separate post for others encountering the same challenge.
To clarify:
Broken link. http://www.e30zone.net/e30zonewiki/inde ... eplacement
vs
“Fixed” link. http://www.e30zone.net/e30wiki/index.ph ... eplacement
“Keep lowering your standards until you achieve your goal.”
Oseanosea
E30 Zone Newbie
E30 Zone Newbie
Posts: 36
Joined: Fri Jan 18, 2019 1:32 am
Location: Jupiter, Florida USA

Sat Feb 09, 2019 9:05 pm

May I please confirm the part number for the bulb below?
Attachments
600FCCC2-29EE-4835-82F9-52967B77D56E.jpeg
“Keep lowering your standards until you achieve your goal.”
User avatar
Brianmoooore
E30 Zone Team Member
E30 Zone Team Member
Posts: 47552
Joined: Mon Jan 10, 2005 11:00 pm

Sat Feb 09, 2019 9:32 pm

504 is the 3W lamp for the instrument cluster general illumination. The lamp in your pic. is a 286.
These numbers are the general type number, just like H1 is an E30 headlamp bulb, and a H3 is for a foglamp.
Image
Oseanosea
E30 Zone Newbie
E30 Zone Newbie
Posts: 36
Joined: Fri Jan 18, 2019 1:32 am
Location: Jupiter, Florida USA

Mon Feb 11, 2019 12:39 am

👍Thanks!
“Keep lowering your standards until you achieve your goal.”
Oseanosea
E30 Zone Newbie
E30 Zone Newbie
Posts: 36
Joined: Fri Jan 18, 2019 1:32 am
Location: Jupiter, Florida USA

Sat Feb 23, 2019 3:54 pm

I fixed my dash lights while I had the instrument cluster apart. I can see the speedometer at night! I’ve replaced all of my instrument cluster lights now. Hopefully that’ll be good for a long time!
Thanks for your help!
Attachments
A1181EAF-FC5F-4F07-9433-4C7E11BC16B8.jpeg
“Keep lowering your standards until you achieve your goal.”
User avatar
martauto
E30 Zone Team Member
E30 Zone Team Member
Posts: 3062
Joined: Wed Aug 31, 2005 10:00 pm
Location: leeds

Sat Feb 23, 2019 5:32 pm

They seem very bright, do you have the correct wattage bulbs ?
It is important as they can cause serious damage .

Mart.
E30 316 coupe 1986 (rip)
E30 316 Baur 1987 (Feeling sorry in the drive but alive !!)
E36 318ti Sport (rip)
E46 330 Ci SE (rip)
E46 330 sport (rip)
E46 325 Cab
Post Reply