E53 X5 electricals... help please...

Discuss Non-E30 BMW's in here - No selling!
Post Reply
miniblob
E30 Zone Addict
E30 Zone Addict
Posts: 3057
Joined: Thu Jan 05, 2006 11:00 pm
Location: Croydon
Contact:

Fri Feb 09, 2018 6:31 pm

Just wondering if anyone has knowledge of X5 electrics???

Have had the rear left indicator not working occasionally recently - comes back on when you give it a knock so assumed it's either a loose connection or maybe a bit of damp in there - not really had time to look into it.......
So today, other half was out and called me to say indicators didn't appear to be working at all now, no light flashing on the dash and no clicking noise - told her to just switch off the car, let it reset and see what happens......
She's now (luckily at her destination), left with an X5 that won't start!!!
Rear lights are stuck on, dash shows car as still in 'D' and nothing happens when she turns the key!!! (I'm guessing 'cos it thinks it's in D???)

Anyone got any quick ideas we can try???
Other than leaving it for a few hours and coming back to see if it either works, or if the rear lights have flattened the battery!!!
(It's a 53 plate 3.0 petrol auto, btw!)
327 Touring with bass!!!

>>> WWW.DNRVINYL.CO.UK >>> UK GARAGE SPECIALIST >>>
>>> WWW.DNRVINYL.COM >>> FREE MIX DOWNLOADS!!! >>>
Jesus325iTouring
Frog freak !
Frog freak !
Posts: 11356
Joined: Sun Jan 09, 2005 11:00 pm
Location: Omnipresent!

Fri Feb 09, 2018 7:32 pm

The only time my X5 (4.4) has played up was when the battery was low would have various faults come up, also, my Range Rover will do the same, low battery on that and I get all sorts of errors come up. Duff battery/ altenater is all I can suggest.
Image

X5 V8 for thrills, CRV for chills, Range Rover P38 V8 for sooooo much aggravation...
miniblob
E30 Zone Addict
E30 Zone Addict
Posts: 3057
Joined: Thu Jan 05, 2006 11:00 pm
Location: Croydon
Contact:

Fri Feb 09, 2018 9:03 pm

Batt & Alt appear ok, though I've not actually tested yet - it had a new water pump last week and the garage commented it all seemed good apart from that!!!

Been to see the car briefly and pick the Mrs up - so the dash shows it as in d, even though it's in park - presumably why it won't start!!! Weirdly, the brake lights are also stuck on and the indicators/hazards work outside the car, but the dash light stays on solidly and there's no clicking audible anymore!!!

Fuse 5 seems to be a common blame (from Google), but that fuse appears fine!!!

Any other thoughts!???
327 Touring with bass!!!

>>> WWW.DNRVINYL.CO.UK >>> UK GARAGE SPECIALIST >>>
>>> WWW.DNRVINYL.COM >>> FREE MIX DOWNLOADS!!! >>>
Jesus325iTouring
Frog freak !
Frog freak !
Posts: 11356
Joined: Sun Jan 09, 2005 11:00 pm
Location: Omnipresent!

Fri Feb 09, 2018 10:47 pm

Regards the stuck in D, currently i have a "Trans fail safe" error come up (which puts he car in go slow). Having it plugged in the fault says selector sensor fault. Looked under the gear shifter boot, it has a very sticky oil with dust all over the general area, the chap who plugged it in suggested blasting it with wd40 to loosen any sticky muck as this may be upsetting the sensor. Since doing this, i have used the car twice and the error hasn't come back. Even if it does, a second hand complete shifter and sensor can be had for sub £50 on Ebay.

As for the lights, X5's are known to have issues as I understand it with the back driver side light cluster, yet no one really seems to know why. I would suggest stripping this down to it's bones to check all wiring, soldering etc. Maybe you have a bad earth somewhere?

I had a back brake light out, but just seemed to be a dodgy bulb, not blown, just dodgy.
Image

X5 V8 for thrills, CRV for chills, Range Rover P38 V8 for sooooo much aggravation...
miniblob
E30 Zone Addict
E30 Zone Addict
Posts: 3057
Joined: Thu Jan 05, 2006 11:00 pm
Location: Croydon
Contact:

Fri Feb 09, 2018 10:58 pm

Interesting to know about the selector sensor!!!

There is also a brake light (side light) out on the drivers side, but has been like it for a couple of weeks, but it is the actual brake lights (including the high level one above the rear screen), which are stuck on!!!
A bad earth would normally give a failure, or random, incorrect combos with the lights on!!!

Also, forgot to mention that the locking would not work from the key, so we could not lock the car!!!
I tried the button in the car and it worked the first time, but not again since then!!!
Didn't work from the key in the door, but I've never tried that before either, so may not have worked anyway!!!
327 Touring with bass!!!

>>> WWW.DNRVINYL.CO.UK >>> UK GARAGE SPECIALIST >>>
>>> WWW.DNRVINYL.COM >>> FREE MIX DOWNLOADS!!! >>>
miniblob
E30 Zone Addict
E30 Zone Addict
Posts: 3057
Joined: Thu Jan 05, 2006 11:00 pm
Location: Croydon
Contact:

Fri Feb 09, 2018 11:00 pm

I have seen on some forums that the i-bus can get confused and lock up, but not really sure how to reset it, other than disconnecting the battery for an hour or more!!!
327 Touring with bass!!!

>>> WWW.DNRVINYL.CO.UK >>> UK GARAGE SPECIALIST >>>
>>> WWW.DNRVINYL.COM >>> FREE MIX DOWNLOADS!!! >>>
Jesus325iTouring
Frog freak !
Frog freak !
Posts: 11356
Joined: Sun Jan 09, 2005 11:00 pm
Location: Omnipresent!

Fri Feb 09, 2018 11:04 pm

To be honest, that would be a good starting point, disconnecting the battery for a time. I'm out of other suggestions having not had many problems. Funny you should mention the key, I lost my remote fob shortly after buying the car, so I only ever use the key. Not sure what is activated in terms of security using just the key?
Image

X5 V8 for thrills, CRV for chills, Range Rover P38 V8 for sooooo much aggravation...
Jesus325iTouring
Frog freak !
Frog freak !
Posts: 11356
Joined: Sun Jan 09, 2005 11:00 pm
Location: Omnipresent!

Fri Feb 09, 2018 11:11 pm

Have you tried messing about with the sport button? Read a while ago about people who have selector issues using the sport button to get the shifter to "wake up"
Image

X5 V8 for thrills, CRV for chills, Range Rover P38 V8 for sooooo much aggravation...
miniblob
E30 Zone Addict
E30 Zone Addict
Posts: 3057
Joined: Thu Jan 05, 2006 11:00 pm
Location: Croydon
Contact:

Fri Feb 09, 2018 11:50 pm

Hmmm, you mean the traction/dsc button?
For sport mode we just knock the shifter to the left and then knock it forward/backward from there for manual gears!!!

Unfortunately we had to go out though so I've had to leave it outside our friend house for now - just worried I'll be adding a flat battery to that list by the morning when I get back!!!
327 Touring with bass!!!

>>> WWW.DNRVINYL.CO.UK >>> UK GARAGE SPECIALIST >>>
>>> WWW.DNRVINYL.COM >>> FREE MIX DOWNLOADS!!! >>>
Jesus325iTouring
Frog freak !
Frog freak !
Posts: 11356
Joined: Sun Jan 09, 2005 11:00 pm
Location: Omnipresent!

Sat Feb 10, 2018 1:28 am

Yes sorry, knock to the left. My Range Rover has the Sport button...doh! Good luck with the car in the morning, will be interested to know how you get on.
Image

X5 V8 for thrills, CRV for chills, Range Rover P38 V8 for sooooo much aggravation...
miniblob
E30 Zone Addict
E30 Zone Addict
Posts: 3057
Joined: Thu Jan 05, 2006 11:00 pm
Location: Croydon
Contact:

Sat Feb 10, 2018 11:03 am

Ha ha, yeah, what a fail!!!!!!
So obviously it has a flat battery now, so went to disconnect the battery........... and obviously the boot is just on a button, so you can't open that to get to the battery. Great.
So you need jump leads connected under the bonnet, to open the boot!!!
Luckily our mate has some jump leads in his car, but he's not there!!! I'll have to go back again later when I can slip out of work - will try and jump the car first, but assuming it still won't do anything, I can then get in the boot, to disconnect the battery, leave it a few hours and then go back tonight and try and jump it again!!!

Remembering why I hate new cars!!!
Been tempted to get something more modern and quick recently, but I think I'll be on ebay tonight looking for a sub £1k shitter, that just works!!!
327 Touring with bass!!!

>>> WWW.DNRVINYL.CO.UK >>> UK GARAGE SPECIALIST >>>
>>> WWW.DNRVINYL.COM >>> FREE MIX DOWNLOADS!!! >>>
miniblob
E30 Zone Addict
E30 Zone Addict
Posts: 3057
Joined: Thu Jan 05, 2006 11:00 pm
Location: Croydon
Contact:

Sat Feb 10, 2018 1:03 pm

Alrighty... jump leads on, turned the key, fired straight up!!!!!
ABS/DSC/Airbag lights on for about a min, but then cleared. Nothing wrong with it!!!
Didn't think the battery would've been flat enough to reset the car like disconnecting it, however, when I first went back earlier, I did notice there were no interior lights, no radio, no dim rear lights, nothing but the battery/oil pressure lights on the dash, so I'm guessing below a certain voltage it realises and cuts everything off?!?!?!

So would that have cleared all the fault codes, or will it plug in next week and tell me what went wrong???
I'm guessing it might not be easy to track the problem and it'll prob happen again - not ideal on the heavily pregnant gf's car, so we'll prob be swapping for a while now, leaving me with the bus!!!!!!
327 Touring with bass!!!

>>> WWW.DNRVINYL.CO.UK >>> UK GARAGE SPECIALIST >>>
>>> WWW.DNRVINYL.COM >>> FREE MIX DOWNLOADS!!! >>>
Jesus325iTouring
Frog freak !
Frog freak !
Posts: 11356
Joined: Sun Jan 09, 2005 11:00 pm
Location: Omnipresent!

Sat Feb 10, 2018 2:48 pm

Would you believe it, jumped in mine to pop down to Tesco, flat battery..lol

Sounds like it may be a low battery issue, glad you have it started so easily!

Right old drama with the battery in the boot bit daft if you ask me, mine is now going to stay on charge for 48 hours, should be fine, it's only flat because i didn't use it for a month then made two small trips in it, so much computing stuff in them anything less than 100% in the battery is asking for aggro. My RR goes flat in about a day, though as I only use it once a week, i just got in the habit of leaving it on charge all the time.

Regards faults, when you plug it in, they should all still be logged on the computer, my selector sensor fault was logged. Nice that there was no other historic faults logged though.

Let us know what the log is when you've had it plugged in.

Out of interest, can you not jump start the car from the terimnals under the bonnet?
Image

X5 V8 for thrills, CRV for chills, Range Rover P38 V8 for sooooo much aggravation...
Jesus325iTouring
Frog freak !
Frog freak !
Posts: 11356
Joined: Sun Jan 09, 2005 11:00 pm
Location: Omnipresent!

Sat Feb 10, 2018 3:07 pm

miniblob wrote: but I think I'll be on ebay tonight looking for a sub £1k shitter, that just works!!!
You want one of these...

https://www.ebay.co.uk/itm/1999-Honda-C ... SwVVRaa2zT

I use one as a daily, and recently bought my wife one as a daily as well.

They are, in short, brilliant.

Simple, reliable, comfortable, practical, I could go on.

My wifes has aircon and a few other extras, mine is a lowly model, but with bugger all miles and full service.

Put new brake pads on mine last week, only one spanner required and about 20 mins work, oh and only cost £28.

Heres ours, mine was £300 (The white one ,lucky buy on ebay, absolute steal!), wifes was £800, neary in mint condition.

Image
Image

X5 V8 for thrills, CRV for chills, Range Rover P38 V8 for sooooo much aggravation...
miniblob
E30 Zone Addict
E30 Zone Addict
Posts: 3057
Joined: Thu Jan 05, 2006 11:00 pm
Location: Croydon
Contact:

Sat Feb 10, 2018 3:35 pm

Ha, typical about the battery!!!
I did jump it from the point under the bonnet, was just assuming the batt would need to be disconnected to reset all the electronics - didn't expect it to start!!!
I know the log was clear on Monday as the guy in the workshop I use cleared it for me after he changed the water pump, (also looking into intermittent airbag light and parking sensors!!!)
Will report back when I can!!!

Not a fan of the Hondas personally - mate of mines parents have had one since new and to be honest, sound like nothing but problems - no idea why they've kept it so long!!! They must've been unlucky!!!
327 Touring with bass!!!

>>> WWW.DNRVINYL.CO.UK >>> UK GARAGE SPECIALIST >>>
>>> WWW.DNRVINYL.COM >>> FREE MIX DOWNLOADS!!! >>>
Jesus325iTouring
Frog freak !
Frog freak !
Posts: 11356
Joined: Sun Jan 09, 2005 11:00 pm
Location: Omnipresent!

Sat Feb 10, 2018 7:43 pm

Reckon they had a Friday afternoon turd, ours are brilliant. I speak only for the MK1 though.
Image

X5 V8 for thrills, CRV for chills, Range Rover P38 V8 for sooooo much aggravation...
Jesus325iTouring
Frog freak !
Frog freak !
Posts: 11356
Joined: Sun Jan 09, 2005 11:00 pm
Location: Omnipresent!

Tue Feb 27, 2018 9:48 pm

Any updates Blob?
Image

X5 V8 for thrills, CRV for chills, Range Rover P38 V8 for sooooo much aggravation...
miniblob
E30 Zone Addict
E30 Zone Addict
Posts: 3057
Joined: Thu Jan 05, 2006 11:00 pm
Location: Croydon
Contact:

Sun Mar 04, 2018 10:58 pm

Errrrrrr, had a baby, (well, the other half did!!!) - got the diagnostic tool setup on my laptop but not had a chance to look into it yet!!!
Car drives faultlessly now, with only the airbag light coming on when someone is in the passenger seat - which I knew about!!!
Will update when I finally get round to investigating properly!!!
327 Touring with bass!!!

>>> WWW.DNRVINYL.CO.UK >>> UK GARAGE SPECIALIST >>>
>>> WWW.DNRVINYL.COM >>> FREE MIX DOWNLOADS!!! >>>
Jesus325iTouring
Frog freak !
Frog freak !
Posts: 11356
Joined: Sun Jan 09, 2005 11:00 pm
Location: Omnipresent!

Mon Mar 05, 2018 11:16 am

Thats a pretty sizeable update! Congrats to both :P
Image

X5 V8 for thrills, CRV for chills, Range Rover P38 V8 for sooooo much aggravation...
User avatar
fixedwheelnut
E30 Zone Regular
E30 Zone Regular
Posts: 474
Joined: Sun Nov 20, 2005 11:00 pm
Location: South East London

Wed Mar 14, 2018 12:14 am

Sounds like the I-Bus shorted to earth or positive, most popular for that fault is kids have put coins in the CD drive of the radio, take it and give it a shake, if it rattles take the top off and remove them :)

Failing that water ingress some where? is it damp anywhere ?
Post Reply